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COLLEGE OF ENGINEERING & TECHNOLOGY 

(An Autonomous college under VTU) 

                                                                                                    

DEPARTMENT OF COMPUTER & APPLICATIONS 

VISION 
 To empower BCA students with essential computer application skills and practical knowledge to enhance academic           

performance, professional competence, and readiness for the digital workplace. 

MISSION 
M1: To provide strong practical foundations in computer applications such as word processing, 

spreadsheets, presentations, and document preparation for effective academic and 

professional usage. 

M2: To train students in using modern software tools to analyze data, create documents, reports, charts, 

and presentations to solve real-world problems. 

M3: To develop analytical thinking, problem-solving ability, accuracy, and efficiency through hands-on 

laboratory exercises and assignments. 

M4: To enhance communication skills, teamwork, and presentation skills through structured lab 

activities and project-based learning. 

M5: To introduce technical documentation tools such as LaTeX and encourage professional reporting 

practices, lifelong learning, and adaptability to emerging technologies.

ESSENTIALS OF COMPUTER LABORATORY 25BCL108 
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Program Outcome: 

 PO1: Knowledge Application: Apply fundamental computer concepts and basic software 
tools to perform essential computational tasks. 

 PO2: Problem Solving: Identify, analyze, and solve basic computing problems using 
appropriate software applications. 

 PO3: Technical Skills: Develop hands-on skills in operating systems, word processing, 
spreadsheets, and presentation tools. 

 

 PO4: Ethics and Safety: Demonstrate responsible use of computers by following digital 
ethics, cyber safety practices, and data protection guidelines. 

 

 PO5:Communication Skills: Use digital tools effectively to create documents, 
spreadsheets, and presentations for clear communication and reporting. 

 

 PO6: Lifelong Learning: Engage in continuous learning to keep pace with emerging 
software tools, technologies, and computing practices. 

 
 
Program Educational Objectives (PEOs) 

 

  PEO1: To provide foundational knowledge of computer operations, software tools, and 
internet usage. 

 PEO2: To enable students to apply computer skills for academic tasks, data handling, 
and professional documentation. 

 PEO3: To cultivate responsible digital citizens who follow safe computing practices and 
ethical digital behavior. 

 PEO4: To encourage interdisciplinary learning by integrating computing skills with 
various academic and professional domains. 
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Program Specific Outcome (PSO): 

PSO1. Basic Computing Skills: Understand computer components, operating system functions, and 

essential software applications. 

PSO2. Productivity Tools: Use word processors, spreadsheets, and presentation  software to create 

professional documents, perform calculations, and design visual and reports. 

PSO3. Digital Practices: Apply safe internet practices, file management techniques, and data 

organization skills in computing environments. 

PSO4. Ethical and Professional Use: Demonstrate ethical behavior in digital communication, cyber 

safety, and responsible handling of digital information. 
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                                                          ESSENTIALS OF COMPUTER LABORATORY 

ESSENTIALS OF COMPUTER LABORATORY SEMESTER I 

Course Code 25BCL108 CIE Marks 50 
Teaching Hours/Week (L: P: SDA) 1:2:0 

SEE Marks 50 

Total Hours of Pedagogy 14 Sessions Total Marks 100 

Credits 02 Exam Hours 03 
Type of the Course Practical 

 

Course Objectives: 

This course will enable students to : 

 Learn to identify computer peripherals and components, assemble and disassemble them, and troubleshoot 

basic hardware issues. 

 Gain skills in installing various operating systems, configuring system settings, and maintaining the system 

using built-in tools. 

 Develop proficiency in using word processors, spreadsheets, presentation software, and internet browsers for 

various tasks. 

 Acquire the ability to edit multimedia content and create flowcharts using Flowgorithm 

software for basic programming tasks. 

 

                                                                            Syllabus 

                                                                               Part A 

1. Word Processor assignment to demonstrate usage of Page Setup, Page Background and Paragraph option of Page Layout tab by 

writing the description about Computer and its characteristics. 

2. Word Processor assignment to demonstrate Bullets and Numbering, Headers and footers. 

3. Word Processor assignment to demonstrate usage of mail merge by creating a letter to invite your parents for the annual day 

event. Prepare at least 5 letters. 

4. Word Processor assignment to demonstrate usage of tables and encryption by preparing the timetable. 

5. Demonstrate usage of formulas and charts in spreadsheet as directed below: 

a. Create a spreadsheet with following components: 

 

 

 

 

 

 

SL No Student 

Name 

Sub 1 Sub 2 Sub 3 Total Percentage Grade 

        



Dept of BCA, NCET 7  

b. Insert the name and marks of 3 subjects of 5 or more students. 

c. Calculate total marks obtained and percentage. 

d. Calculate the grade by applying following criteria: 

i. If percentage >=90, then grade A 

ii. If percentage >=75 and <90, then grade B 

iii. If percentage >=60 and <75, then grade C 

iv. If percentage >=50 and <60, then grade D 

v. If percentage <50, then grade E 

e. Insert column charts for various subjects 

f. Insert pie chart for one student depicting composition of 3 subject marks. 

 

6. Demonstrate usage of data validation in the spreadsheet as directed below: 

a. Create a spreadsheet with following components: 

 

 

 

 

 

 

 

a. Insert 5 employee details in the columns Emp No., Emp Name, DOB, Basic Salary. 

b. Add drop-down data validation for Gender and Designation columns 

c. Add a formula to calculate Age based on DOB 

d. Add the formula to calculate 

i. DA as 35% of Basic salary, 

ii. HRA as 25% of Basic salary 

iii. Deduction as 10% of Basic salary 

e. Add the formula to calculate Gross Salary and Net Salary 

 

7. Demonstrate conditional formatting in spreadsheet as directed below: 

 

USN 

 

Name 

 

Date 1 

 

Date 2 

 

Date 3 

 

- 

 

Date N 

No. of Classes 

Attended 

Attendance 

Percentage 

         

a. Create an attendance spreadsheet for 10 students. 

b. Mark P for present and A for absent for respective dates. 

c. Apply formula to calculate “No. of classes attended” and “Attendance Percentage” columns. 

d. Apply conditional formatting to highlight a student if “Attendance Percentage” is less than 85%. 

 

8. Create a power-point presentation to demonstrate the following: 

a. Layout option 

b. Insertion of date, time and slide numbers 

c. Insertion of Symbols 

 

9. Create a power-point presentation to demonstrate the following: 

a. Themes 

b. Transitions 

c. Animation 

 

10. Create a power-point presentation to demonstrate the following: 

a. Rehearse Timings 

b. Narrations 

Slide Sorter 

Emp 

No 

Emp Name Gender Designation DOB Age Basic 

Salary 

DA HRA Gross 

Salary 

Deduction Net 

Salary 
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                                                         Part B 

1. Introduction to LaTeX Software 

a. Install LaTeX software on your system. 

b. Create a simple LaTeX document. 

c. Compile the document to generate a PDF output. 

d. Explore and explain the structure of a basic LaTeX document (preamble, document body, etc.). 

 

2. Working with LaTeX Templates 

a. Download a predefined LaTeX template (e.g., article, report). 

b. Customize the template by adding your name, title, and date. 

c. Add different sections and subsections to organize the content. 

d. Compile and review the document structure. 

 

3. Including Text in LaTeX 

a. Create a new LaTeX document using the article template. 

b. Add paragraphs of text, including bold, italic, and underlined text. 

c. Implement lists (ordered, unordered, and description lists). 

                    d. Use special characters and symbols in the text. 

4. Creating Tables in LaTeX 

a. Create a LaTeX document and include a table using the `tabular` environment. 

b. Add rows, columns, and format the table with borders. 

c. Merge cells horizontally and vertically. 

d. Include a caption and label for the table for referencing. 

 

5. Incorporating Math Formulae and Generating Reports 

a. Create a LaTeX document to write mathematical equations using the `equation` and `align` environments. 

b. Include inline and display-style equations. 

c. Add Greek symbols, fractions, and superscripts/subscripts. 

d. Compile the document to generate a final report with a title page, table of contents, and numbered sections. 
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Course Outcomes: 

 
After the completion of the Course, students will be able to 

CO1.  Understand the identification, assembly, disassembly, and basic troubleshooting of computer hardware 

components, including peripherals, CPU, and system hardware. 

CO2. Gain hands-on experience with networking basics, including LAN and WiFi setup and configuration. 

CO3. Develop practical skills in installing and configuring various operating systems, including Windows, UNIX/Linux,  

            and  dual booting, along with system maintenance using BIOS settings, Registry Editor, and third-party tools. 

  CO4. Enhance proficiency in using office productivity software, including word processors, 

              spreadsheets, presentation tools, and multimedia editing software. 

  CO5. Apply logical thinking to create flowcharts and perform tasks using algorithms software for  

              arithmetic    operations, shape area calculations, and understanding arrays and recursion. 
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Part A 

1.Word Processor assignment to demonstrate usage of 

Page Setup, Page Background and Paragraph option of Page 

Layout tab by writing the description about Computer and 

its characteristics. 

Step 1: Create document & add content 

Computer 

A computer is an electronic device that can store, retrieve, and process 

data. 

It works according to a set of instructions called a program to perform 

various tasks such as calculations, data processing, document creation, 

and communication. 

 

Characteristics of a Computer 

 

1. Speed: 

A computer can process data and perform calculations much faster than 

humans. It can execute millions of instructions per second. 

 

2. Accuracy: 

Computers are highly accurate. Errors usually occur only because of 

wrong input or program instructions, not due to the computer itself. 

 

3. Storage Capacity: 

Computers can store vast amounts of data and retrieve it quickly 

whenever needed. This data can be text, images, audio, or video. 
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   4.Versatility: 

A computer can perform a wide variety of tasks — from playing games 

to solving complex scientific equations. 

 

Step 2. Page setup 

 Word: ̀ Layout → Margins → Custom Margins` → set (e.g.) 

Top/Bottom 1", Left/Right 1". 

 Orientation: `Layout → Orientation → Portrait` (or 

Landscape   if asked). 

 Paper size: `Layout → Size → A4`. 
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Step 3. Page background 

 

   *Word: `Design → Page Color` → choose a light color or 

`Fill Effects → Picture` to use an image. 
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 Step4.Paragraph formatting (spacing, alignment, 

indentation) 

 

* Select the paragraph → `Home → Paragraph group`: 

* Alignment: choose `Left`, `Center` or `Justify`. 

* Spacing Before/After: set `Before = 6 pt`, `After = 6 pt`. 

* Indentation: `Paragraph → Special → First line → 0.5"` 

to show first-line indent. 
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Step 5. Output 

 

                                                                                    OR 

 

 

 

* Save as `Computer.docx`. 
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2. Word Processor assignment to demonstrate Bullets and 

Numbering, Headers and footers 

Step1. Create lists 

 

* Type five lines for characteristics, select them → `Home 

→ Bullets`. 

     * Type three lines for uses, select → `Home → Numbering`. 

Characteristics of a Computer 

1. Speed: 

A computer can process data and perform calculations much faster than 

humans. It can execute millions of instructions per second. 

 

2. Accuracy: 

Computers are highly accurate. Errors usually occur only because of 

wrong input or program instructions, not due to the computer itself. 

 

3. Storage Capacity: 

Computers can store vast amounts of data and retrieve it quickly 

whenever needed. This data can be text, images, audio, or video. 

 

   4.Versatility: 

A computer can perform a wide variety of tasks — from playing games 

to solving complex scientific equations. 
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Step2. Add header and footer 

* `Insert → Header` → choose blank or template → type 

document title (center). 

* `Insert → Footer` → type your name (left) and `Insert → Page 

Number` → choose bottom right. 
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Step3. Formatting   

* Make header font `Bold, 14 pt` and footer `Italic, 10 pt`. 
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Step 4. Output 
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3.Word Processor assignment to demonstrate usage of mail merge 

by creating a letter to invite your parents for the annual day event. 

Prepare at least 5 letters. 

 

Step 1: Create the Main Letter 

 

Open MS Word → create a new document and type the main invitation letter. 

Example letter: 

 

Annual Day Invitation Letter 

 

[Your School Name] 

[School Address] 

[Date] 

 

Dear [Parent_Name], 

 

We are delighted to invite you to our school’s Annual Day Celebration to be held on 

[Event_Date] at [Venue]. Your presence will inspire our students and make the event 

more special. 

 

The program will begin at [Start_Time] and include cultural performances, awards, and 

other exciting events. 

 

We look forward to welcoming you and your family. 

 

Warm regards,   

[Principal_Name]   

Principal, [School_Name] 

 

Step 2: Create a Data Source 
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Open MS Excel → Enter details for at least 5 parents. 

 

Save the file as ParentsList.xlsx. 

Step 3: Link Data Source to Word 

In Word: 

1. Go to Mailings → Start Mail Merge → Letters 

2. Click Select Recipients → Use an Existing List 

3. Choose your Excel file (ParentsList.xlsx) 

4. Insert merge fields:  

Click Insert Merge Field → Parent_Name, etc. 

 

Your letter will now look like: 

 

Dear «Parent_Name», 

We are delighted to invite you to our school’s Annual Day Celebration 
to be held on «Event_Date» at «Venue». 

... 

Warm regards, 

«Principal_Name» 

Principal, «School_Name» 

Step 4: Preview and Finish 
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1. Click Preview Results to see each personalized letter. 

2. Then click Finish & Merge → Edit Individual Documents 

3. Save the final letters as a single file or print them. 

 

Output  

5 personalized letters for 5 parents. 

Each letter should contain their name and same event details. 
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4.Word Processor assignment to demonstrate usage of tables and 
encryption by preparing the timetable. 

Step1 Insert table 

  * `Insert → Table` → choose 6 columns (Day + 5 or 7 periods 

depending on layout) and 6 rows (header + 5 weekdays). 

Example header row: ̀ Day | Period1 | Period2 | Period3 | Period4 

| Period5`. 

 

Step2. Fill subjects 

 * Populate each cell with subject names (e.g., Math, Science). 

Day  Period 1 Period 2 Period 3 Period 4 Period 5 

MON      

TUE      

WED      

THUR      

FRI      
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Step3. Format table 

   * Select table → `Table Design`: 

   * Choose `Shading` for header row. 

   * Apply `Borders` → `All Borders`. 

   * Adjust column widths by dragging. 

Step4. Encrypt (Protect) document 

 * ̀ File → Info → Protect Document → Encrypt with Password` 

→ enter password and confirm. 

Day  Period 1 Period 2 Period 3 Period 4 Period 5 

MON      

TUE maths  cs   

WED      

THUR      

FRI      

Day  Period 1 Period 2 Period 3 Period 4 Period 5 

MON  C  Eng CE EVS Iks 

TUE maths Evs  C Kan CE 

WED CE Iks Eng C maths 

THUR Evs CE  maths Nptel Kan 
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5.Demonstrate usage of formulas and charts in spreadsheet as 

directed below: 

 

a. Create a spreadsheet with following components: 

b. Insert the name and marks of 3 subjects of 5 or more students. 

c. Calculate total marks obtained and percentage. 

d. Calculate the grade by applying following criteria: 

i. If percentage >=90, then grade A 

ii. If percentage >=75 and <90, then grade B 

iii. If percentage >=60 and <75, then grade C 

SL No Student 

Name 

Sub 1 Sub 2 Sub 3 Total Percentage Grade 
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iv. If percentage >=50 and <60, then grade D 

v. If percentage <50, then grade E 

e. Insert column charts for various subjects 

f. Insert pie chart for one student depicting composition of 3 

subject marks 

 

solution : Step 1: Create a spreadsheet 

 

Step 2: a b c->Formulas to calculate: 

 Total: =SUM(C2:E2)         

Percentage: =F2/300*100 

Grade: 
=IF(G2>=90,"A",IF(G2>=75,"B",IF(G2>=60,"C",IF(G2>=50,"D","E")))) 

e->Column Chart for various Subjects: 

SL No 
Student 
Name Sub1 Sub2 Sub3 Total Percentage Grade 

1 Raja 85 78 92 255 85 B 

2 Priya 95 91 88 274 91.3333 A 

3 Amit 64 59 72 195 65 C 

4 Neha 48 52 46 146 48.6667 E 

5 Suresh 75 80 68 223 74.3333 C 
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f-> Pie chart for one student depicting composition of 3 subject marks 

 

 

6.Demonstrate usage of data validation in the spreadsheet as 

directed below: 

a. Create a spreadsheet with following components: 

 

 

a. Insert 5 employee details in the columns Emp No., Emp 

Name, DOB, Basic Salary. 

b. Add drop-down data validation for Gender and Designation 

columns Add a formula to calculate Age based on DOB 

 

0

20

40

60

80

100

Raja Priya Amit Neha Suresh

M
ar

ks

Students

Marks by Subject

Sub1

Sub2

Sub3

Raja

1 2 3

 

Emp 

No 
Emp 

Name 
Gender Designation DOB Age 

Basic 

Salary 
DA HRA 

Gross 

Salary 
Deduction 

Net 
Salary 
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c. Add the formula to calculate 

    DA as 35% of Basic salary, 

    HRA as 25% of Basic salary 

    Deduction as 10% of Basic salary 

d. Add the formula to calculate Gross Salary and Net Salary 

solution : Step 1: Create a spreadsheet 

 

Step 2: b c d->Formulas to calculate: 

Age:                 =DATEDIF(E2,TODAY(),"Y")         Deduction:      =G2*0.1                                                                                                                                                                                                                                  
Net Salary:         =J2-K2 

DA:                   =G2*0.35 

HRA:                 =G2*0.25 

Gross Salary:  =G2+H2+I2 

 

7.Demonstrate conditional formatting in spreadsheet as 

directed below: 

 
 

 

Emp 
No 

Emp 
Name Gender Designation DOB Age 

Basic 
Salary DA HRA 

Gross 
Salary Deduction 

Net 
Salary 

101 Kavya Female Lecturer 
1990-
05-12 35 25000 8750 6250 40000 2500 37500 

102 Raj Male 
Assistant 
Prof 

1985-
11-03 40 40000 14000 10000 64000 4000 60000 

103 Anu Female Lab Asst 
1996-
02-20 29 18000 6300 4500 28800 1800 27000 

 

 

USN 

 

 

Name 

 

 

Date 1 

 

 

Date 2 

 

 

Date 3 

 

 

- 

 

 

Date N 

No. of 

Classes 

Attended 

Attendance 

Percentage 
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a. Create an attendance spreadsheet for 10 students 

b. Mark P for present and A for absent for respective dates. 

c. Apply formula to calculate “No. of classes attended” and 

“Attendance Percentage” columns 

d. Apply conditional formatting to highlight a student if 

“Attendance Percentage” is less than 85%. 

 

solution : Step 1: Create a spreadsheet 

Step 2: ->Formulas to calculate: 

->No. of classes attended:      =COUNTIF(C2:L2,"P") 

-> Attendance Percentage:     =M2/10*100 

 

 

d. conditional formatting to highlight a student if “Attendance 

Percentage” is less than 85%. 

 

 

 

 

 

 

USN Name Date1 Date2 Date3 Date4 Date5 Date6 Date7 Date8 Date9 Date10 

No. of 
Classes  
Attended 

Attendance 
Percentage 

1NT21CS001 Rohan P P A P P A P P P A 7 70 

1NT21CS002 Maya P P P P P P P P P P 10 100 

1NT21CS003 Isha A P A P A P A P A P 5 50 

Attendance 

Percentage 

70 

100 

50 
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8. Create a power-point presentation to demonstrate the 

following: 

a. Layout option 

b. Insertion of date, time and slide numbers 

c. Insertion of Symbols. 

Solution: 

A. Layout Option 

Step 1:Open PowerPoint 

Start a new presentation → A blank slide will appear. 

Step 2:Go to the Home tab 

On the ribbon (top menu), click Home. 

Step 3:Click Layout 

You will see a button called Layout with a dropdown 

arrow. 

Step 4:Choose any layout 

Different layouts: 

* Title Slide 

* Title and Content 

* Two Content 

* Comparison 

* Picture with Caption 
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B. Insert Date, Time & Slide Numbers 

Step 1:Go to the Insert tab 

Click Insert on the top menu. 

Step 2:Click Header & Footer 

A box will open. 

Step 3:Tick the checkboxes 

✔ Date and time 

✔ Slide number 

Choose whether you want: 

▪ Fixed date 

▪ Automatically update date 

Step 4:Click Apply to All 

Date, time and slide numbers will appear on every slide. 
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C. Insert Symbols 

Step 1: Go to Insert tab 

Click Insert from the top menu. 

Step 2:Click Symbol 

A small window will open showing many symbols. 

Step 3:Choose the symbol you want 
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Step 4:Click Insert 

The symbol will be added to your slide. 

 

 

9. Create a power-point presentation to demonstrate 

the following: 

a. Themes 

b. Transitions 

c. Animation 

Solution: step 1: Create a slide with content 

a. Themes 

 Themes change the overall look 

 Includes fonts, colors, and effects 
  Theme – Steps 

 Open your PowerPoint presentation. 

 Go to the Design tab. 

 In the Themes group, choose any theme. 
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To customize: 

 Click Variants to change colors or fonts. 

 The theme will automatically apply to all slide 

 

Themes 
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b. Transitions 

 Transitions control slide entry 

  Examples: Fade, Wipe, Push 

Transitions – Steps 

1. Select the slide where you want to add a transition. 

2. Go to the Transitions tab. 

3. Choose a transition effect (e.g., Fade, Wipe, Push). 

4. Adjust settings: 

o Duration: change speed. 

o Sound (optional). 

5. Click Apply to All if you want the same transition on every slide. 

6. Preview using the Play from Start button. 
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C. Animations 

 Animations apply to objects 

  Types: Entrance, Emphasis, Exit 

Animations – Steps 

1. Select the object you want to animate (text, picture, shape, etc.). 

2. Go to the Animations tab.p 

3. Choose an animation type: 

o Entrance (appear, fly-in, fade-in) 

o Emphasis (spin, pulse, grow) 

o Exit (fade-out, fly-out) 

o Motion paths 

4. Click Animation Pane (optional) to adjust order. 

5. Set Start options: 

o On Click 



Dept of BCA, NCET 

43 

 

o With Previous 

o After Previous 

6. Adjust the timing, delay, and duration as needed. 

7. Preview the result using the Preview button. 

 

 

 

 

10. Create a power-point presentation to 

demonstrate the following: 

a. Rehearse Timings 

b. Narrations 

c. Slide Sorter 
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Solution: 

A. Rehearse Timings – Steps 

1. Open your PowerPoint presentation. 

2. Go to the Slide Show tab. 

3. Click Rehearse Timings. 

4. PowerPoint will start slide show mode with a timer. 

5. Practice presenting each slide — timing will be recorded. 

6. Click Next (→ key) to go to the next slide. 

 

 
 

B. Narrations – Steps 

1. Go to the Slide Show tab. 

2. Click Record Narration or Record Slide Show. 

3. Choose whether you want to record: 

o Narration only 

o Narration with slide timings 

4. Click Start Recording. 

5. Speak clearly as the slides progress. 

6. Stop recording when done. 
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7. Save the narration.

 

 

 

C. Slide Sorter – Steps 

1. Go to the View tab. 

2. Click Slide Sorter. 

3. All slides will appear as thumbnails. 

4. Drag and drop slides to rearrange them. 

5. You can delete, duplicate, or apply transitions to multiple slides 

from here. 
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Part B 

1. Introduction to LaTeX Software 

a. Install LaTeX software on your system. 

b. Create a simple LaTeX document. 

c. Compile the document to generate a PDF output. 

d. Explore and explain the structure of a basic LaTeX document 
(preamble, document body, etc.) 

a. Install LaTeX software 

Solution: 

You can install any LaTeX distribution. Most commonly: 

OS Software 

Windows MiKTeX 

macOS MacTeX 

Linux TeX Live 

After installing, install an editor like TeXstudio, Overleaf (online), or VS Code with LaTeX extension. 

 

b. Create a simple LaTeX document 

Solution (Code): 

\documentclass{article} 

\begin{document} 

Hello, this is my first LaTeX document! 

\end{document} 
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c. Compile the document to generate PDF 

Solution: 

Click Compile / Run (PDFLaTeX) in TeXstudio or Overleaf → PDF is generated. 

 

 

d. Structure of a basic LaTeX document 

Solution: 

Part                           Meaning 

Preamble                   Declares document class and packages 

Document Body                      Contains visible content 
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\documentclass{article}   % Preamble 

\usepackage{amsmath} 

\begin{document}          % Document Body 

Hello World 

\end{document} 

 

 

 

 

2. Working with LaTeX Templates 

a. Download a predefined LaTeX template (e.g., article, report). 

b. Customize the template by adding your name, title, and 

date. 

c. Add different sections and subsections to organize the 

content. 

d. Compile and review the document structure. 

 

a. Download a predefined template 
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Solution: 

Use an article, report, or book class template from Overleaf or LaTeX project. 

 

  

 

 

b. Customize with name, title, and date 

c. Add sections and subsections 

 

 

 

 

 

 

 

 

\documentclass[12pt, a4paper]{report} 

\usepackage[utf8]{inputenc} 
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\usepackage{graphicx} 

\usepackage{amsmath} 

 

\title{My First LaTeX Report} 

\author{John Doe} 

\date{\today} 

 

\begin{document} 

 

\maketitle   % Corrected: \make title → \maketitle 

\tableofcontents   % Corrected: \table of contents → \tableofcontents 

 

\chapter{Introduction} 

This is the introduction to my report. It provides an overview of the topic. 

 

\section{Background} 

Here, I discuss the relevant background information. 

 

\chapter{Methodology} 

This chapter details the methods used in the study. 

 

\end{document}

 

 

d. Compile and review output 

Click Compile → check formatting and structure. 
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3. Including Text in LaTeX 
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a. Create a new LaTeX document using the article template. 

b. Add paragraphs of text, including bold, italic, and underlined text. 

c. Implement lists (ordered, unordered, and description lists). 

d. Use special characters and symbols in the text. 

\documentclass{article} 

\usepackage[normalem]{ulem} 

\begin{document} 

 

This is a paragraph written in the article template. In this sentence we use  

\textbf{bold}, \textit{italic} and \underline{underlined} text to format content. 

 

Here are some fruit items shown using different types of lists: 

\textbf{Unordered List:} 

\begin{itemize} 

    \item Apple 

    \item Banana 

    \item Mango 

\end{itemize} 

\textbf{Ordered List:} 

\begin{enumerate} 

    \item Apple 

    \item Banana 

    \item Mango 

\end{enumerate} 

\textbf{Description List:} 

\begin{description} 

    \item[Apple] A sweet red fruit. 

    \item[Banana] A long yellow fruit. 

    \item[Mango] A juicy tropical fruit. 

\end{description} 
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Special characters: \%, \$, \&, \#, \_, \{ \} 

Math symbol example: \( \alpha + \beta = \gamma \) 

\end{document} 

output 

 

 
 

4. Creating Tables in LaTeX 

a. Create a LaTeX document and include a table using the tabular 

environment. 

b. Add rows, columns, and format the table with borders. 
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c. Merge cells horizontally and vertically. 

d. Include a caption and label for the table for referencing. 

 

\documentclass{article} 

\usepackage{multirow} % For merging rows 

\usepackage{array}    % Better table formatting 

 

\begin{document} 

Below is an example of a formatted table with merged cells, caption, and label. 

\begin{table}[h!] 

\centering 

\caption{Fruit Quantity Table} 

\label{tab:fruits} 

 

\begin{tabular}{|c|c|c|} 

\hline 

\textbf{Fruit} & \textbf{Category} & \textbf{Quantity} \\ \hline 

\multirow{2}{*}{Apple} & Red Apple & 10 \\ \cline{2-3} 

                       & Green Apple & 8 \\ \hline 

Banana & \multicolumn{2}{c|}{15 (Merged Cell)} \\ \hline 

\multirow{2}{*}{Mango} & Raw Mango & 5 \\ \cline{2-3} 

                       & Ripe Mango & 12 \\ \hline 

\end{tabular} 

\end{table} 

The above Table~\ref{tab:fruits} shows different types of fruits and their quantities. 
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\end{document}

 

 

 
 

5. Incorporating Math Formulae and Generating Reports 

a. Create a LaTeX document to write mathematical equations using 

the equation and align environments. 

b. Include inline and display-style equations. 

c. Add Greek symbols, fractions, and superscripts/subscripts. 
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d. Compile the document to generate a final report with a title page, 

table of contents, and numbered sections. 

\documentclass{report} 

\usepackage{amsmath} 

 

\title{Math in LaTeX} 

\author{Student Name} 

\date{\today} 

 

\begin{document} 

\maketitle 

\tableofcontents 

 

\chapter{Mathematics in LaTeX} 

This document shows how to write mathematical equations in LaTeX. 

 

Inline example: The equation \( a^2 + b^2 = c^2 \) is called the Pythagorean theorem. 

\section{Display Equation} 

A display equation example: 

\[ 

\frac{x+y}{2} = z 

\] 

\section{Equation Environment} 

\begin{equation} 

E = mc^2 

\end{equation} 

\section{Align Environment} 

\begin{align} 

x + y &= z \\ 

a^2 + b^2 &= c^2 

\end{align} 

\section{Symbols and Expressions} 

Greek symbols example: \( \alpha, \beta, \gamma \) 
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Fraction with subscript and superscript example: 

\[ 

F = G \frac{m_1 m_2}{r^2} 

\] 

\end{document} 

output 
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